{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-14270 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-14270 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-14270 is a high-severity vulnerability in ThemeComplete Extra Checkout Options - addon for Extra Product Options plugin, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-14270 and fix it if it is affected.\n\nWhat it is: CVE-2026-14270 is a high-severity vulnerability in ThemeComplete Extra Checkout Options - addon for Extra Product Options plugin, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-14270 in the wild and no public exploit code.\n\nAffected product: ThemeComplete Extra Checkout Options - addon for Extra Product Options plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-14270/ (Markdown: https://insights.sbomify.com/CVE-2026-14270/index.md)","id":"CVE-2026-14270","markdown":"https://insights.sbomify.com/CVE-2026-14270/index.md","name":"CVE-2026-14270","record":{"aliases":["GHSA-628w-9cvh-c6wq"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can upload PHP files via missing authorization checks, leading to remote code execution on WordPress sites using this plugin.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"The Extra Checkout Options (addon for Extra Product Options \u0026 Add-Ons for WooCommerce) plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 2.3.2. This is due to missing authorization and nonce validation in the eco_save_settings() function, which allows low-privileged authenticated users to modify the tc_eco_custom_file_types upload allowlist setting, combined with insufficient authorization on the wc_eco_upload_file AJAX action. This makes it possible for authenticated attackers, with Subscriber-level access and above, to allow PHP uploads, upload a PHP file using the frontend upload nonce exposed on cart and checkout pages, and achieve remote code execution. NOTE: This vulnerability was partially fixed in version 2.3.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"File upload in Extra Checkout Options - addon for Extra Product Options plugin","id":"CVE-2026-14270","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"file_upload","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"IBM DataPower Gateway Incorrect Authorization","id":"CVE-2026-14273"},"packages":[],"prev":{"headline":"IBM DataPower Gateway Buffer Overflow","id":"CVE-2026-14269"},"products":["Extra Checkout Options - addon for Extra Product Options plugin"],"published":"2026-07-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-29","vendors":["ThemeComplete"]},"summary":"Authenticated subscribers can upload PHP files via missing authorization checks, leading to remote code execution on WordPress sites using this plugin.","url":"https://insights.sbomify.com/CVE-2026-14270/"}