# CVE-2026-14270: File upload in Extra Checkout Options - addon for Extra Product Options plugin

> Authenticated subscribers can upload PHP files via missing authorization checks, leading to remote code execution on WordPress sites using this plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-628w-9cvh-c6wq

## What is CVE-2026-14270?

CVE-2026-14270 is a high-severity vulnerability in ThemeComplete Extra Checkout Options - addon for Extra Product Options plugin, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Extra Checkout Options (addon for Extra Product Options & Add-Ons for WooCommerce) plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 2.3.2. This is due to missing authorization and nonce validation in the eco_save_settings() function, which allows low-privileged authenticated users to modify the tc_eco_custom_file_types upload allowlist setting, combined with insufficient authorization on the wc_eco_upload_file AJAX action. This makes it possible for authenticated attackers, with Subscriber-level access and above, to allow PHP uploads, upload a PHP file using the frontend upload nonce exposed on cart and checkout pages, and achieve remote code execution. NOTE: This vulnerability was partially fixed in version 2.3.2.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-14270?


## How do I fix CVE-2026-14270?

No fix has been published for CVE-2026-14270 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-14270 being exploited?

There is no known exploitation of CVE-2026-14270 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14270 and fix it if it is affected.

What it is: CVE-2026-14270 is a high-severity vulnerability in ThemeComplete Extra Checkout Options - addon for Extra Product Options plugin, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14270 in the wild and no public exploit code.

Affected product: ThemeComplete Extra Checkout Options - addon for Extra Product Options plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14270/ (Markdown: https://insights.sbomify.com/CVE-2026-14270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14270
- OSV: https://osv.dev/vulnerability/CVE-2026-14270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14270/
Summaries are generated and may contain mistakes; the official description above is the record.
