CVE-2026-14288 Use of Incorrectly-Resolved Name or Reference in GitLab

Low 3.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-14288?

CVE-2026-14288 is a low-severity vulnerability in Gitlab Gitlab, published on 21 Oct 2026.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.4 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that under certain conditions could have allowed an authenticated to bypass a required merge request approval policy on a protected branch due to improper access control during approval rule synchronization.

Weakness: CWE-706

Which versions are affected by CVE-2026-14288?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.4.019.3.6, 19.4.3, 19.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-14288?

Upgrade gitlab to a fixed version for your release line: 19.3.6, 19.4.3 or 19.5.1.

Is CVE-2026-14288 being exploited?

There is no known exploitation of CVE-2026-14288 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-14288, GHSA-xxf3-q32p-w3cc.

Is CVE-2026-14288 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free