# CVE-2026-14362: Denial of service via crafted push/pull gossip message in memberlist

> An attacker with network access can cause a denial of service by exhausting memory via crafted gossip messages in the memberlist library.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** CLEANSTART-2026-NY71627, CLEANSTART-2026-WV25742, GHSA-6r3r-6rpf-v429

## What is CVE-2026-14362?

CVE-2026-14362 is a medium-severity denial of service vulnerability in HashiCorp Shared library, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

HashiCorp memberlist before version 0.6.0 is vulnerable to a denial-of-service issue in its push/pull state handling that may allow an attacker with network access to the gossip port to exhaust memory on a receiving node and cause the process to terminate. This vulnerability (CVE-2026-14362) is fixed in memberlist 0.6.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-14362?


## How do I fix CVE-2026-14362?

Upgrade to a fixed version.

## Is CVE-2026-14362 being exploited?

There is no known exploitation of CVE-2026-14362 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14362 and fix it if it is affected.

What it is: CVE-2026-14362 is a medium-severity denial of service vulnerability in HashiCorp Shared library, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14362 in the wild and no public exploit code.

Affected product: HashiCorp Shared library. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14362/ (Markdown: https://insights.sbomify.com/CVE-2026-14362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14362
- OSV: https://osv.dev/vulnerability/CVE-2026-14362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14362/
Summaries are generated and may contain mistakes; the official description above is the record.
