CVE-2026-1446 XSS issue is Esri ArcGIS Pro versions 3.6.0 and earlier

Medium 5.0 Published Updated

A local attacker can execute arbitrary scripts in ArcGIS Pro by supplying malicious strings to a specific dialog, requiring no elevated privileges.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-1446?

CVE-2026-1446 is a medium-severity cross-site scripting vulnerability in Esri ArcGIS Pro, published on 26 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

There is a Cross‑Site Scripting (XSS) issue in Esri ArcGIS Pro versions 3.6.0 and earlier. ArcGIS Pro is a desktop application, and exploitation is limited to local users interacting with the application; no privileged role or elevated permissions are required beyond standard local user access. A local attacker can supply malicious strings that may be rendered and executed when a specific dialog within ArcGIS Pro is opened. This issue is fixed in ArcGIS Pro version 3.6.1.

Weakness: CWE-79

Which versions are affected by CVE-2026-1446?

It affects 1 product.

Products include Esri Arcgis Pro.

How do I fix CVE-2026-1446?

No fix has been published for CVE-2026-1446 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-1446 being exploited?

There is no known exploitation of CVE-2026-1446 in the wild and no public exploit code.

Sources

Also known as GHSA-rwq8-4chg-7w5w.

Is CVE-2026-1446 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free