# CVE-2026-14500: Bulk Order Update for WooCommerce <= 1.6 - Unauthenticated Arbitrary File Read via 'csv_url' Parameter

> Unauthenticated attackers can read arbitrary files on the server via the csv_url parameter in the Bulk Order Update for WooCommerce plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-74pw-3rq8-72px

## What is CVE-2026-14500?

CVE-2026-14500 is a medium-severity path traversal vulnerability in sayantandas20 Bulk Order Update for WooCommerce, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Bulk Order Update for WooCommerce plugin for WordPress is vulnerable to Arbitrary File Read in versions up to, and including, 1.6. This is due to the bouw_fetch_csv_data() AJAX handler being registered on the wp_ajax_nopriv_ hook with no capability or nonce check, and passing the attacker-supplied csv_url POST parameter — filtered only by esc_url_raw() (which leaves absolute filesystem paths intact) and validate_file() (which only rejects '..' traversal patterns) — directly into fopen()/fgetcsv() and reflecting the first parsed line in the JSON response. This makes it possible for unauthenticated attackers to read the first line of arbitrary files on the server (such as /etc/passwd) and to use the handler as a file-existence oracle.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-14500?


## How do I fix CVE-2026-14500?

No fix has been published for CVE-2026-14500 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-14500 being exploited?

There is no known exploitation of CVE-2026-14500 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14500 and fix it if it is affected.

What it is: CVE-2026-14500 is a medium-severity path traversal vulnerability in sayantandas20 Bulk Order Update for WooCommerce, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14500 in the wild and no public exploit code.

Affected product: sayantandas20 Bulk Order Update for WooCommerce. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14500/ (Markdown: https://insights.sbomify.com/CVE-2026-14500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14500
- OSV: https://osv.dev/vulnerability/CVE-2026-14500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14500/
Summaries are generated and may contain mistakes; the official description above is the record.
