# CVE-2026-14534: Fickling check_safety() bypass via unlisted standard library modules (_posixsubprocess, site, atexit)

> Attackers can bypass safety checks in fickling to execute arbitrary code via malicious pickle payloads using unlisted standard library modules.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-m6fh-58r7-x697, GHSA-v8cr-9jrc-fwf9, PYSEC-2026-2149

## What is CVE-2026-14534?

CVE-2026-14534 is a high-severity unsafe deserialization vulnerability in trailofbits fickling, published on 4 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Trail of Bits fickling versions up to and including 0.1.10 do not include the Python standard library modules _posixsubprocess, site, and atexit in the UNSAFE_IMPORTS denylist (fickle.py). Because these modules are absent from the denylist, fickling's check_safety() function returns LIKELY_SAFE with zero findings for pickle payloads that invoke dangerous functions including _posixsubprocess.fork_exec (C-level process spawner capable of executing arbitrary binaries), site.execsitecustomize (executes arbitrary site customization code), and atexit._run_exitfuncs (triggers all registered exit handler callbacks). The fickling.load() API chains check_safety() into pickle.loads() as an explicit security gate; a LIKELY_SAFE verdict causes the payload to be deserialized and executed. This shares the same root cause as CVE-2026-22607 (cProfile), CVE-2025-67748 (pty), and CVE-2025-67747 (marshal/types). OvertlyBadEvals does not flag these modules because they are standard library imports. UnsafeImports does not flag them because they are not in the denylist. The UnusedVariables heuristic is defeated by the SETITEMS opcode pattern.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-14534?

1 open source package ship an affected version, including fickling. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fickling` | PyPI | All versions | 0.1.11 |

Products: Trailofbits Fickling.

## How do I fix CVE-2026-14534?

Upgrade fickling to 0.1.11 or later.

## Is CVE-2026-14534 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-14534 exists.

## Other vulnerabilities in trailofbits fickling

- [CVE-2026-22606](https://insights.sbomify.com/CVE-2026-22606/): Fickling has a bypass via runpy.run_path() and runpy.run_module() (high 8.9)
- [CVE-2026-22607](https://insights.sbomify.com/CVE-2026-22607/): Fickling Blocklist Bypass: cProfile.run() (high 8.9)
- [CVE-2026-22608](https://insights.sbomify.com/CVE-2026-22608/): Fickling vulnerable to use of ctypes and pydoc gadget chain to bypass detection (high 8.9)
- [CVE-2026-22609](https://insights.sbomify.com/CVE-2026-22609/): Fickling has Static Analysis Bypass via Incomplete Dangerous Module Blocklist (high 8.9)
- [CVE-2026-22612](https://insights.sbomify.com/CVE-2026-22612/): Fickling vulnerable to detection bypass due to "builtins" blindness (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14534 and fix it if it is affected.

What it is: CVE-2026-14534 is a high-severity unsafe deserialization vulnerability in trailofbits fickling, published on 4 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-14534 exists.

Affected packages and fixed versions:
- fickling (PyPI): affected all versions; fixed in 0.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14534/ (Markdown: https://insights.sbomify.com/CVE-2026-14534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14534
- OSV: https://osv.dev/vulnerability/CVE-2026-14534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14534/
Summaries are generated and may contain mistakes; the official description above is the record.
