CVE-2026-1458 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An unauthenticated attacker can cause denial of service by uploading malicious files, requiring GitLab administrators to upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1458?

CVE-2026-1458 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 8.0 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions could have allowed an unauthenticated user to cause denial of service by uploading malicious files.

Weakness: CWE-434, CWE-770

Which versions are affected by CVE-2026-1458?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.0.018.6.6, 18.7.4, 18.8.4

Products include Gitlab Gitlab.

How do I fix CVE-2026-1458?

Upgrade gitlab to a fixed version for your release line: 18.6.6, 18.7.4 or 18.8.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-1458 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1458 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1458, GHSA-m668-xfwp-34x6, MINI-2m6h-h43q-hhrc, MINI-34q7-j2mp-x975, MINI-3vh6-r48v-m2hv, MINI-3xj8-v5g4-pw2h and 25 more.

Is CVE-2026-1458 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free