{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-14611 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-14611 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-14611 is a medium-severity vulnerability in DeepMyst Mysti, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-14611 and fix it if it is affected.\n\nWhat it is: CVE-2026-14611 is a medium-severity vulnerability in DeepMyst Mysti, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-14611 in the wild and no public exploit code.\n\nAffected product: DeepMyst Mysti. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-14611/ (Markdown: https://insights.sbomify.com/CVE-2026-14611/index.md)","id":"CVE-2026-14611","markdown":"https://insights.sbomify.com/CVE-2026-14611/index.md","name":"CVE-2026-14611","record":{"aliases":["GHSA-fwpr-59hh-gr98"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"DeepMyst Mysti library","requires_auth":"low_privilege","summary":"Remote attackers can expose resources via the initProjectMemory function in DeepMyst Mysti, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A vulnerability has been found in DeepMyst Mysti up to 0.4.0. The affected element is the function initProjectMemory of the file src/managers/MemoryManager.ts of the component Per-Project Auto-Memory Handler. Such manipulation of the argument workspacePath leads to exposure of resource. The attack may be performed from remote. Upgrading to version 0.4.0 is sufficient to fix this issue. The name of the patch is 6d709229b5199f6769fb3cf763e5122dcc43c079. It is advisable to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"DeepMyst Mysti Per-Project Auto-Memory MemoryManager.ts initProjectMemory exposure of resource","id":"CVE-2026-14611","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"Freeipa: ipa: idm: freeipa: off-by-one buffer overflows in ipa-otpd oauth2.c during oauth2 device authorization","id":"CVE-2026-14612"},"packages":[],"prev":{"headline":"Open Asset Import Library Assimp CSM File CSMLoader.cpp InternReadFile heap-based overflow","id":"CVE-2026-14610"},"products":["Mysti"],"published":"2026-07-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-06","vendors":["DeepMyst"]},"summary":"Remote attackers can expose resources via the initProjectMemory function in DeepMyst Mysti, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2026-14611/"}