# CVE-2026-14611: DeepMyst Mysti Per-Project Auto-Memory MemoryManager.ts initProjectMemory exposure of resource

> Remote attackers can expose resources via the initProjectMemory function in DeepMyst Mysti, requiring an upgrade to mitigate.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-fwpr-59hh-gr98

## What is CVE-2026-14611?

CVE-2026-14611 is a medium-severity vulnerability in DeepMyst Mysti, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability has been found in DeepMyst Mysti up to 0.4.0. The affected element is the function initProjectMemory of the file src/managers/MemoryManager.ts of the component Per-Project Auto-Memory Handler. Such manipulation of the argument workspacePath leads to exposure of resource. The attack may be performed from remote. Upgrading to version 0.4.0 is sufficient to fix this issue. The name of the patch is 6d709229b5199f6769fb3cf763e5122dcc43c079. It is advisable to upgrade the affected component.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-14611?


## How do I fix CVE-2026-14611?

No fix has been published for CVE-2026-14611 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-14611 being exploited?

There is no known exploitation of CVE-2026-14611 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14611 and fix it if it is affected.

What it is: CVE-2026-14611 is a medium-severity vulnerability in DeepMyst Mysti, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14611 in the wild and no public exploit code.

Affected product: DeepMyst Mysti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14611/ (Markdown: https://insights.sbomify.com/CVE-2026-14611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14611
- OSV: https://osv.dev/vulnerability/CVE-2026-14611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14611/
Summaries are generated and may contain mistakes; the official description above is the record.
