# CVE-2026-14620: webpack-dev-server vulnerable to cross-site request forgery via internal developer endpoints

> An attacker can trigger state-changing actions on webpack-dev-server endpoints via CSRF, potentially opening arbitrary files or causing denial of service.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** CLEANSTART-2026-KY31390, GHSA-f5vj-f2hx-8m93, MINI-532c-4x6r-ccmf, MINI-hg8r-9rpg-fqfh, MINI-q4j5-87vh-65pc, MINI-r2xx-45w2-m8w5, MINI-vfpr-qm2f-9hgf, MINI-wgcp-wq5g-vgg3, ROOT-APP-NPM-CVE-2026-14620

## What is CVE-2026-14620?

CVE-2026-14620 is a medium-severity vulnerability in webpack-dev-server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

webpack-dev-server versions 5.2.5 and earlier expose two internal developer endpoints, /webpack-dev-server/open-editor and /webpack-dev-server/invalidate, that perform state-changing actions on any GET request without verifying that the request originated from the dev server's own page. Any website a developer visits while the dev server is running can trigger these endpoints cross-origin with no interaction beyond the visit. An attacker can open an arbitrary existing local file in the developer's editor, including files outside the project root, and repeated requests can spawn editor processes and force recompilations that degrade the developer's machine. Patches: upgrade to webpack-dev-server 5.2.6. Workarounds: none.

Weakness: CWE-749 (Exposed Dangerous Method or Function), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-14620?

2 open source packages ship an affected version, including webpack-dev-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webpack-dev-server` | npm | All versions | 5.2.6 |
| `webpack-dev-server` | npm | All versions | 5.2.6 |

Products: Webpack.js Webpack-Dev-Server.

## How do I fix CVE-2026-14620?

Upgrade webpack-dev-server to 5.2.6 or later.

## Is CVE-2026-14620 being exploited?

There is no known exploitation of CVE-2026-14620 in the wild and no public exploit code.

Public exploit code:

- webpack_devserver 5.2.5 -  CSRF (exploitdb)

## Other vulnerabilities in webpack-dev-server

- [CVE-2026-112085](https://insights.sbomify.com/CVE-2026-112085/): webpack-dev-server vulnerable to cross-origin WebSocket access via proxied upgrades (high 8.2)
- [CVE-2018-14732](https://insights.sbomify.com/CVE-2018-14732/): Missing Origin Validation in webpack-dev-server (high 7.5)
- [CVE-2025-30360](https://insights.sbomify.com/CVE-2025-30360/): webpack-dev-server users' source code may be stolen when they access a malicious web site with non-Chromium based browser (medium 6.5)
- [CVE-2026-114348](https://insights.sbomify.com/CVE-2026-114348/): webpack-dev-server vulnerable to information disclosure via Host validation bypass in the open-editor endpoint (medium 5.3)
- [CVE-2026-14631](https://insights.sbomify.com/CVE-2026-14631/): webpack-dev-server vulnerable to denial of service via a malformed Host or Origin header (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14620 and fix it if it is affected.

What it is: CVE-2026-14620 is a medium-severity vulnerability in webpack-dev-server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-14620 in the wild and no public exploit code.

Affected packages and fixed versions:
- webpack-dev-server (npm): affected all versions; fixed in 5.2.6
- webpack-dev-server (npm): affected all versions; fixed in 5.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14620/ (Markdown: https://insights.sbomify.com/CVE-2026-14620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14620
- OSV: https://osv.dev/vulnerability/CVE-2026-14620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14620/
Summaries are generated and may contain mistakes; the official description above is the record.
