CVE-2026-14643 undici vulnerable to cross-user information disclosure via whitespace around equals in Cache-Control directives
Attackers can access other users' authenticated data via cache poisoning in undici when shared caching is enabled and specific whitespace is used in Cache-Control directives.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-14643?
CVE-2026-14643 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's cache interceptor mishandles optional whitespace placed around the equals sign of a qualified no-cache or private Cache-Control directive. In undici from 7.0.0 up to before 7.29.0 and from 8.0.0 up to before 8.9.0, the parser either drops the directive or stores a field name with literal quote characters, so the cache decision fails to recognize the qualification and the response is stored. In shared-cache mode, this lets a response containing one user's authenticated data be served from cache to a later caller, including an unauthenticated one, when both requests resolve to the same cache key. It affects applications that enable the cache interceptor in shared mode, forward Authorization headers upstream, and receive cacheable responses with qualified directives padded with whitespace around the equals sign. This is the whitespace-around-equals variant that the fix for CVE-2026-9678 did not normalize, and it is fixed in undici 7.29.0 and 8.9.0.
Which versions are affected by CVE-2026-14643?
4 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 8.0.0 | 8.9.0 |
undici npm | From 8.0.0 | 8.9.0 |
Products include Nodejs Undici.
How do I fix CVE-2026-14643?
Upgrade undici to a fixed version for your release line: 7.29.0 or 8.9.0.
Is CVE-2026-14643 being exploited?
There is no known exploitation of CVE-2026-14643 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-DN19608, CLEANSTART-2026-UG48995, CLEANSTART-2026-ZY12459, CLSA-2026-1791466657, DEBIAN-CVE-2026-14643, ECHO-6dbc-5c15-636c and 17 more.