# CVE-2026-14643: undici vulnerable to cross-user information disclosure via whitespace around equals in Cache-Control directives

> Attackers can access other users' authenticated data via cache poisoning in undici when shared caching is enabled and specific whitespace is used in Cache-Control directives.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 30 Jul 2026
- **Also known as:** CLEANSTART-2026-DN19608, CLEANSTART-2026-UG48995, CLEANSTART-2026-ZY12459, CLSA-2026-1791466657, DEBIAN-CVE-2026-14643, ECHO-6dbc-5c15-636c, GHSA-jr45-8vmc-qm54, MINI-4p6g-9wm3-34cf, MINI-52g8-9cv9-xpjj, MINI-5jcv-678r-5c86, MINI-82p6-q535-8pgx, MINI-867v-cr6w-7wf2, MINI-8vwg-76gc-jh4j, MINI-gh22-99wq-22f4, MINI-h8fp-7hjj-8j37, MINI-hvfr-m8q8-v493, MINI-mcrg-cqwh-m76x, MINI-pm78-xm79-j37f, MINI-qh9f-p25q-rh7p, MINI-r66q-7q5c-j9c5, MINI-xxv8-gx55-hcr4, ROOT-APP-NPM-CVE-2026-14643, UBUNTU-CVE-2026-14643

## What is CVE-2026-14643?

CVE-2026-14643 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's cache interceptor mishandles optional whitespace placed around the equals sign of a qualified no-cache or private Cache-Control directive. In undici from 7.0.0 up to before 7.29.0 and from 8.0.0 up to before 8.9.0, the parser either drops the directive or stores a field name with literal quote characters, so the cache decision fails to recognize the qualification and the response is stored. In shared-cache mode, this lets a response containing one user's authenticated data be served from cache to a later caller, including an unauthenticated one, when both requests resolve to the same cache key. It affects applications that enable the cache interceptor in shared mode, forward Authorization headers upstream, and receive cacheable responses with qualified directives padded with whitespace around the equals sign. This is the whitespace-around-equals variant that the fix for CVE-2026-9678 did not normalize, and it is fixed in undici 7.29.0 and 8.9.0.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information), CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-14643?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.0.0 | 7.29.0 |
| `undici` | npm | From 7.0.0 | 7.29.0 |
| `undici` | npm | From 8.0.0 | 8.9.0 |
| `undici` | npm | From 8.0.0 | 8.9.0 |

Products: Nodejs Undici.

## How do I fix CVE-2026-14643?

Upgrade undici to a fixed version for your release line: 7.29.0 or 8.9.0.

## Is CVE-2026-14643 being exploited?

There is no known exploitation of CVE-2026-14643 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14643 and fix it if it is affected.

What it is: CVE-2026-14643 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14643 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.0.0; fixed in 7.29.0
- undici (npm): affected from 7.0.0; fixed in 7.29.0
- undici (npm): affected from 8.0.0; fixed in 8.9.0
- undici (npm): affected from 8.0.0; fixed in 8.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14643/ (Markdown: https://insights.sbomify.com/CVE-2026-14643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14643
- OSV: https://osv.dev/vulnerability/CVE-2026-14643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14643/
Summaries are generated and may contain mistakes; the official description above is the record.
