# CVE-2026-14663: PostgreSQL pgcrypto, for OpenSSL-disabled ciphers, silently encrypts to and decrypts from cleartext

> Attackers can recover cleartext data or bypass integrity checks when using disabled OpenSSL ciphers in PostgreSQL pgcrypto functions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-14663, AZL-95723, BELL-CVE-2026-14663, BIT-postgresql-2026-14663, DEBIAN-CVE-2026-14663, ECHO-f3cd-3a09-6569, GHSA-6hh9-353p-vfvp, MINI-5q87-258f-7wpq, MINI-8w8r-952g-942r, MINI-gp92-9m84-xh8v, MINI-hxhq-v94q-w6xq, MINI-r4j4-mxq6-4rw3, MINI-xxxf-297r-3pvw, UBUNTU-CVE-2026-14663

## What is CVE-2026-14663?

CVE-2026-14663 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cleartext storage in PostgreSQL pgcrypto disabled ciphers allows a user to recover cleartext, via direct observation of the faulty ciphertext.  The OpenSSL version and OpenSSL configuration determine the disabled ciphers.  If the application accepts encrypted data as input, decryption will succeed even with the wrong key.  This in turn loses the modest protection from the Modification Detection Code (MDC).  Affected functions are pgp_sym_encrypt, pgp_sym_decrypt, pgp_pub_encrypt, pgp_pub_decrypt, pgp_sym_encrypt_bytea, pgp_sym_decrypt_bytea, pgp_pub_encrypt_bytea, and pgp_pub_decrypt_bytea.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-313 (Cleartext Storage in a File or on Disk)

## Which versions are affected by CVE-2026-14663?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-14663?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-14663 being exploited?

There is no known exploitation of CVE-2026-14663 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14663 and fix it if it is affected.

What it is: CVE-2026-14663 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14663 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14663/ (Markdown: https://insights.sbomify.com/CVE-2026-14663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14663
- OSV: https://osv.dev/vulnerability/CVE-2026-14663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14663/
Summaries are generated and may contain mistakes; the official description above is the record.
