CVE-2026-14666 PostgreSQL row security caching disregards role modifications

Medium 4.2 Published Updated

Attackers can bypass row-level security policies by exploiting stale cache entries after role changes, allowing unauthorized data access or modification.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-14666?

CVE-2026-14666 is a medium-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Incomplete tracking in PostgreSQL of changes to role membership, role attributes, and database ownership allows a query to continue using cached row-level security policies after those changes require a different policy, via plan reuse. Stale policies continue until some other event invalidates the cache or connection termination ends the session. This permits a user to complete reads and modifications that were recently permitted but now forbidden. An attacker must tailor an attack to a particular application's pattern of privilege removal and role-specific row security policies. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-1250

Which versions are affected by CVE-2026-14666?

1 open source package ship an affected version, including postgresql. It affects 1 product.

PackageAffectedFixed in
postgresql BitnamiAll versions14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Products include Postgresql Postgresql.

How do I fix CVE-2026-14666?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-14666 being exploited?

There is no known exploitation of CVE-2026-14666 in the wild and no public exploit code.

All Postgresql Postgresql vulnerabilities

Sources

Also known as ALPINE-CVE-2026-14666, AZL-95726, BELL-CVE-2026-14666, BIT-postgresql-2026-14666, DEBIAN-CVE-2026-14666, ECHO-7186-14fb-68a6 and 8 more.

Is CVE-2026-14666 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free