# CVE-2026-14666: PostgreSQL row security caching disregards role modifications

> Attackers can bypass row-level security policies by exploiting stale cache entries after role changes, allowing unauthorized data access or modification.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-14666, AZL-95726, BELL-CVE-2026-14666, BIT-postgresql-2026-14666, DEBIAN-CVE-2026-14666, ECHO-7186-14fb-68a6, GHSA-fvh5-w7wg-xp3g, MINI-2974-5c57-g5v8, MINI-5838-7429-qmrm, MINI-73mm-28hp-xwfh, MINI-j86h-xqr4-xm2v, MINI-m2vj-gj68-86c7, MINI-m8vr-w4v3-vq5w, UBUNTU-CVE-2026-14666

## What is CVE-2026-14666?

CVE-2026-14666 is a medium-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incomplete tracking in PostgreSQL of changes to role membership, role attributes, and database ownership allows a query to continue using cached row-level security policies after those changes require a different policy, via plan reuse.  Stale policies continue until some other event invalidates the cache or connection termination ends the session.  This permits a user to complete reads and modifications that were recently permitted but now forbidden.  An attacker must tailor an attack to a particular application's pattern of privilege removal and role-specific row security policies.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-1250 (Improper Preservation of Consistency Between Independent Representations of Shared State)

## Which versions are affected by CVE-2026-14666?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-14666?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-14666 being exploited?

There is no known exploitation of CVE-2026-14666 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14666 and fix it if it is affected.

What it is: CVE-2026-14666 is a medium-severity missing authorization vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14666 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14666/ (Markdown: https://insights.sbomify.com/CVE-2026-14666/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14666
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14666
- OSV: https://osv.dev/vulnerability/CVE-2026-14666

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14666/
Summaries are generated and may contain mistakes; the official description above is the record.
