# CVE-2026-14668: PostgreSQL ctid type confusion in selectivity estimator discloses derivative of arbitrary read

> An attacker with object creation privileges can exploit a type confusion flaw to recover substantial memory values via a derived calculation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-14668, AZL-95699, BELL-CVE-2026-14668, BIT-postgresql-2026-14668, DEBIAN-CVE-2026-14668, ECHO-23cd-b47c-aa1a, GHSA-ph64-qjwg-mxwq, MINI-cq4x-xmhj-746f, MINI-p659-q8w6-293x, MINI-p94g-jw7j-wpfp, MINI-q3xm-5f4q-cqxg, MINI-vjcp-q68p-84rm, MINI-x4wr-p9x8-8677, ROOT-OS-DEBIAN-11-CVE-2026-14668, UBUNTU-CVE-2026-14668

## What is CVE-2026-14668?

CVE-2026-14668 is a high-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Type confusion regarding input of PostgreSQL ctid data type selectivity estimator allows an object creator to view a calculation derived from the value of an arbitrary 4-byte span of memory, via a chosen non-ctid input.  While the calculation loses precision, substantial memory value recovery appears possible.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2026-14668?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-14668?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-14668 being exploited?

There is no known exploitation of CVE-2026-14668 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14668 and fix it if it is affected.

What it is: CVE-2026-14668 is a high-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14668 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14668/ (Markdown: https://insights.sbomify.com/CVE-2026-14668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14668
- OSV: https://osv.dev/vulnerability/CVE-2026-14668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14668/
Summaries are generated and may contain mistakes; the official description above is the record.
