# CVE-2026-14672: PostgreSQL observable response discrepancy with non-default scram_iterations provides user existence oracle

> An unauthenticated attacker can determine if a user exists by observing SCRAM iteration counts, provided the user has a non-default configuration.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-14672, AZL-95702, BELL-CVE-2026-14672, BIT-postgresql-2026-14672, DEBIAN-CVE-2026-14672, ECHO-1137-4f23-2f4e, GHSA-hp2m-55fj-8mw5, MINI-3v2v-q3jw-92mh, MINI-7wc6-g7wg-6ccq, MINI-p6vc-w22x-qggg, UBUNTU-CVE-2026-14672

## What is CVE-2026-14672?

CVE-2026-14672 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Observable response discrepancy in PostgreSQL SCRAM authentication allows an unauthenticated user to test the existence of a user via observing the SCRAM iteration count.  This requires the probed user to have a non-default scram_iterations count, because the authentication challenge for a nonexistent user reports the default scram_iterations.  Within major versions 16-18, minor versions before PostgreSQL 18.6, 17.11, and 16.15 are affected.  Versions before PostgreSQL 16 are unaffected.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2026-14672?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 16.0.0 | 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-14672?

Upgrade postgresql to a fixed version for your release line: 16.15.0, 17.11.0 or 18.5.0.

## Is CVE-2026-14672 being exploited?

There is no known exploitation of CVE-2026-14672 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14672 and fix it if it is affected.

What it is: CVE-2026-14672 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14672 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 16.0.0; fixed in 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14672/ (Markdown: https://insights.sbomify.com/CVE-2026-14672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14672
- OSV: https://osv.dev/vulnerability/CVE-2026-14672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14672/
Summaries are generated and may contain mistakes; the official description above is the record.
