CVE-2026-14673 PostgreSQL amcheck does not clear untrusted search path
A user with amcheck EXECUTE privilege can escalate privileges to index owners by manipulating the search path to execute arbitrary functions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-14673?
CVE-2026-14673 is a low-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Untrusted search path in PostgreSQL amcheck allows a grantee of amcheck function EXECUTE privilege to execute arbitrary functions as the owners of expression indexes that depend on the search path, via setting a hostile search path before calling the amcheck function. Within major versions 18, 16, 15, and 14, minor versions before PostgreSQL 18.6, 16.15, 15.19, and 14.24 are affected. PostgreSQL 17 is unaffected.
Weakness: CWE-426
Which versions are affected by CVE-2026-14673?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 18.5.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-14673?
Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 18.5.0.
Is CVE-2026-14673 being exploited?
There is no known exploitation of CVE-2026-14673 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-14673, AZL-95681, BELL-CVE-2026-14673, BIT-postgresql-2026-14673, CLSA-2026-1792746510, DEBIAN-CVE-2026-14673 and 8 more.