CVE-2026-14677 PostgreSQL 32-bit pltcl and plperl undersize allocations, via integer wraparound
An integer overflow in PostgreSQL 32-bit builds allows attackers to execute arbitrary code via crafted function bodies in pltcl or plperl.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-14677?
CVE-2026-14677 is a high-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Integer wraparound in PostgreSQL 32-bit builds of pltcl and plperl allows an object creator to cause the server to undersize an allocation and write out-of-bounds via crafted function bodies. This may execute arbitrary code as the operating system user running the database. CVE-2026-6473 had fixed similar problems. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
Weakness: CWE-190
Which versions are affected by CVE-2026-14677?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-14677?
Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.
Is CVE-2026-14677 being exploited?
There is no known exploitation of CVE-2026-14677 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-14677, AZL-95744, BELL-CVE-2026-14677, BIT-postgresql-2026-14677, DEBIAN-CVE-2026-14677, ECHO-c3ac-6939-6dc1 and 9 more.