CVE-2026-14678 PostgreSQL pg_trgm picksplit reads past end of buffer

Medium 4.3 Published Updated

A buffer over-read in PostgreSQL's pg_trgm extension allows a table maintainer to infer limited memory values through index split choices.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-14678?

CVE-2026-14678 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Buffer over-read in PostgreSQL pg_trgm index picksplit function reads past end of a heap buffer. This might allow a table maintainer to infer limited memory values, via the lossy signal of index split choices. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-126

Which versions are affected by CVE-2026-14678?

1 open source package ship an affected version, including postgresql. It affects 1 product.

PackageAffectedFixed in
postgresql BitnamiAll versions14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Products include Postgresql Postgresql.

How do I fix CVE-2026-14678?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

Is CVE-2026-14678 being exploited?

There is no known exploitation of CVE-2026-14678 in the wild and no public exploit code.

All Postgresql Postgresql vulnerabilities

Sources

Also known as ALPINE-CVE-2026-14678, AZL-95753, BELL-CVE-2026-14678, BIT-postgresql-2026-14678, DEBIAN-CVE-2026-14678, ECHO-b5a2-e95f-87e8 and 8 more.

Is CVE-2026-14678 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free