# CVE-2026-14679: PostgreSQL stack buffer overflow in argument match writes 0x0 and 0x1 to server memory

> A stack buffer overflow in PostgreSQL allows attackers to write limited bytes to server memory, potentially causing crashes or code execution.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-14679, AZL-95690, BELL-CVE-2026-14679, BIT-postgresql-2026-14679, DEBIAN-CVE-2026-14679, ECHO-cd45-9423-f52d, GHSA-mpj9-cx22-xp87, MINI-4hjg-79hp-9jpc, MINI-6v5v-vxm5-jggp, MINI-8grx-3g3f-4jh3, MINI-fpv3-35f5-23mf, MINI-q4gf-p6c9-g43p, MINI-wjcc-9fvf-xf5v, ROOT-OS-DEBIAN-11-CVE-2026-14679, UBUNTU-CVE-2026-14679

## What is CVE-2026-14679?

CVE-2026-14679 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Stack buffer overflow in PostgreSQL argument name matching allows an object creator to achieve unknown impacts via OUT parameter count.  The attack can write only 0x0 and 0x1 bytes.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-14679?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-14679?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-14679 being exploited?

There is no known exploitation of CVE-2026-14679 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14679 and fix it if it is affected.

What it is: CVE-2026-14679 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14679 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14679/ (Markdown: https://insights.sbomify.com/CVE-2026-14679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14679
- OSV: https://osv.dev/vulnerability/CVE-2026-14679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14679/
Summaries are generated and may contain mistakes; the official description above is the record.
