{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-14680 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.","what":"CVE-2026-14680 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-14680 and fix it if it is affected.\n\nWhat it is: CVE-2026-14680 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-14680 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-14680/ (Markdown: https://insights.sbomify.com/CVE-2026-14680/index.md)","id":"CVE-2026-14680","markdown":"https://insights.sbomify.com/CVE-2026-14680/index.md","name":"CVE-2026-14680","record":{"aliases":["ALPINE-CVE-2026-14680","AZL-95720","BELL-CVE-2026-14680","BIT-postgresql-2026-14680","DEBIAN-CVE-2026-14680","ECHO-cc36-987c-913e","GHSA-xxfm-85xf-vx5m","MINI-3hgm-7q78-rq96","MINI-5q56-p7vx-9x43","MINI-6c57-wph9-99fv","MINI-6h76-c74h-6h36","MINI-8m8f-5jj4-7rvq","MINI-v23p-mf2m-x538","ROOT-OS-DEBIAN-11-CVE-2026-14680","UBUNTU-CVE-2026-14680"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code as the OS user by exploiting type confusion in internal data types, requiring an upgrade to patched PostgreSQL versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"Type confusion with PostgreSQL \"internal\" data type arguments allows any user to execute arbitrary code as the operating system user running the database, via calls to functions with that argument type.  Type \"internal\" represents a class of mutually-incompatible data structures not intended for access from SQL.  The system intended to prevent such function calls, but this prevention had gaps.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL type confusion via \"internal\" arguments","id":"CVE-2026-14680","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL improper enforcement of GSSAPI encryption when coupled with SSL","id":"CVE-2026-14681"},"packages":[{"ecosystem":"Bitnami","fixed":["14.24.0","15.19.0","16.15.0","17.11.0","18.5.0"],"introduced":["0","15.0.0","16.0.0","17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2026-14680"}],"prev":{"headline":"PostgreSQL stack buffer overflow in argument match writes 0x0 and 0x1 to server memory","id":"CVE-2026-14679"},"products":["PostgreSQL"],"published":"2026-08-13","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-29","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code as the OS user by exploiting type confusion in internal data types, requiring an upgrade to patched PostgreSQL versions.","url":"https://insights.sbomify.com/CVE-2026-14680/"}