{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-14681 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 17.11.0 or 18.5.0.","what":"CVE-2026-14681 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-14681 and fix it if it is affected.\n\nWhat it is: CVE-2026-14681 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-14681 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 17.0.0; fixed in 17.11.0, 18.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-14681/ (Markdown: https://insights.sbomify.com/CVE-2026-14681/index.md)","id":"CVE-2026-14681","markdown":"https://insights.sbomify.com/CVE-2026-14681/index.md","name":"CVE-2026-14681","record":{"aliases":["ALPINE-CVE-2026-14681","BIT-postgresql-2026-14681","DEBIAN-CVE-2026-14681","ECHO-1690-243f-9082","GHSA-gfpv-wrhp-wwh6","MINI-26rm-x4p3-6pm8","MINI-x56w-v36w-rqh4","UBUNTU-CVE-2026-14681"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"Attackers can bypass GSSAPI encryption requirements by negotiating TLS instead, weakening connection security in PostgreSQL.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-924","name":"Improper Enforcement of Message Integrity During Transmission in a Communication Channel"}],"description":"Improper enforcement of message integrity in PostgreSQL GSSAPI support allows a user to negotiate GSSAPI contrary to pg_hba.conf rules, via initial direct TLS connection.  Despite a pg_hba.conf that appears to require GSSAPI, the connection may exchange data over TLS encryption alone.  If the TLS settings are more permissive than the GSS settings, the connection may continue with lesser protection.  Within major versions 17-18, minor versions before PostgreSQL 18.6 and 17.11 are affected.  Versions before PostgreSQL 17 are unaffected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL improper enforcement of GSSAPI encryption when coupled with SSL","id":"CVE-2026-14681","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"security_feature_bypass","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Possible OOM from unbounded up-front allocation on a definite-length read","id":"CVE-2026-14682"},"packages":[{"ecosystem":"Bitnami","fixed":["17.11.0","18.5.0"],"introduced":["17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2026-14681"}],"prev":{"headline":"PostgreSQL type confusion via \"internal\" arguments","id":"CVE-2026-14680"},"products":["PostgreSQL"],"published":"2026-08-13","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-29","vendors":["n/a"]},"summary":"Attackers can bypass GSSAPI encryption requirements by negotiating TLS instead, weakening connection security in PostgreSQL.","url":"https://insights.sbomify.com/CVE-2026-14681/"}