# CVE-2026-14681: PostgreSQL improper enforcement of GSSAPI encryption when coupled with SSL

> Attackers can bypass GSSAPI encryption requirements by negotiating TLS instead, weakening connection security in PostgreSQL.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-14681, BIT-postgresql-2026-14681, DEBIAN-CVE-2026-14681, ECHO-1690-243f-9082, GHSA-gfpv-wrhp-wwh6, MINI-26rm-x4p3-6pm8, MINI-x56w-v36w-rqh4, UBUNTU-CVE-2026-14681

## What is CVE-2026-14681?

CVE-2026-14681 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper enforcement of message integrity in PostgreSQL GSSAPI support allows a user to negotiate GSSAPI contrary to pg_hba.conf rules, via initial direct TLS connection.  Despite a pg_hba.conf that appears to require GSSAPI, the connection may exchange data over TLS encryption alone.  If the TLS settings are more permissive than the GSS settings, the connection may continue with lesser protection.  Within major versions 17-18, minor versions before PostgreSQL 18.6 and 17.11 are affected.  Versions before PostgreSQL 17 are unaffected.

Weakness: CWE-924 (Improper Enforcement of Message Integrity During Transmission in a Communication Channel)

## Which versions are affected by CVE-2026-14681?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 17.0.0 | 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-14681?

Upgrade postgresql to a fixed version for your release line: 17.11.0 or 18.5.0.

## Is CVE-2026-14681 being exploited?

There is no known exploitation of CVE-2026-14681 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14681 and fix it if it is affected.

What it is: CVE-2026-14681 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14681 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 17.0.0; fixed in 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14681/ (Markdown: https://insights.sbomify.com/CVE-2026-14681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14681
- OSV: https://osv.dev/vulnerability/CVE-2026-14681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14681/
Summaries are generated and may contain mistakes; the official description above is the record.
