CVE-2026-14793 Craft CMS reorder-sets Endpoint GlobalsController.php actionReorderSets authorization

Medium 5.3 Published Updated

Remote attackers can bypass authorization checks in the reorder-sets endpoint to modify global sets without proper permissions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-14793?

CVE-2026-14793 is a medium-severity missing authorization vulnerability in Craft CMS, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was detected in Craft CMS up to 4.18.0.1. Affected is the function actionReorderSets of the file src/controllers/GlobalsController.php of the component reorder-sets Endpoint. The manipulation results in authorization bypass. The attack can be executed remotely. Upgrading to version 4.18.1 is able to address this issue. The patch is identified as 9bd05c91e6a7e6da5e949ec41a31c220c059aa04. The affected component should be upgraded.

Weakness: CWE-639, CWE-285

Which versions are affected by CVE-2026-14793?

4 open source packages ship an affected version, including craftcms/cms.

PackageAffectedFixed in
craftcms/cms PackagistFrom 4.0.0-RC14.18.1
craftcms/cms PackagistFrom 4.0.0-RC14.18.1
craftcms/cms PackagistFrom 5.0.0-RC15.10.3
craftcms/cms PackagistFrom 5.0.0-RC15.10.3

How do I fix CVE-2026-14793?

Upgrade craftcms/cms to a fixed version for your release line: 4.18.1 or 5.10.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-14793 being exploited?

There is no known exploitation of CVE-2026-14793 in the wild and no public exploit code.

Sources

Also known as GHSA-9p7c-v5x3-rfx8.

Is CVE-2026-14793 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free