{"answers":{"affected":"4 open source packages ship an affected version, including craftcms/cms.","exploited":"There is no known exploitation of CVE-2026-14793 in the wild and no public exploit code.","fix":"Upgrade craftcms/cms to a fixed version for your release line: 4.18.1 or 5.10.3.","what":"CVE-2026-14793 is a medium-severity missing authorization vulnerability in Craft CMS, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-14793 and fix it if it is affected.\n\nWhat it is: CVE-2026-14793 is a medium-severity missing authorization vulnerability in Craft CMS, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-14793 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.1\n- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.1\n- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.3\n- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-14793/ (Markdown: https://insights.sbomify.com/CVE-2026-14793/index.md)","id":"CVE-2026-14793","markdown":"https://insights.sbomify.com/CVE-2026-14793/index.md","name":"CVE-2026-14793","record":{"aliases":["GHSA-9p7c-v5x3-rfx8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Craft CMS","requires_auth":"low_privilege","summary":"Remote attackers can bypass authorization checks in the reorder-sets endpoint to modify global sets without proper permissions.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"A vulnerability was detected in Craft CMS up to 4.18.0.1. Affected is the function actionReorderSets of the file src/controllers/GlobalsController.php of the component reorder-sets Endpoint. The manipulation results in authorization bypass. The attack can be executed remotely. Upgrading to version 4.18.1 is able to address this issue. The patch is identified as 9bd05c91e6a7e6da5e949ec41a31c220c059aa04. The affected component should be upgraded.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Craft CMS reorder-sets Endpoint GlobalsController.php actionReorderSets authorization","id":"CVE-2026-14793","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":6,"next":{"headline":"Craft CMS Charts Endpoint ChartsController.php actionGetNewUsersData improper authorization","id":"CVE-2026-14794"},"packages":[{"ecosystem":"Packagist","fixed":["4.18.1"],"introduced":["4.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-9p7c-v5x3-rfx8"},{"ecosystem":"Packagist","fixed":["4.18.1"],"introduced":["4.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-9p7c-v5x3-rfx8"},{"ecosystem":"Packagist","fixed":["5.10.3"],"introduced":["5.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-9p7c-v5x3-rfx8"},{"ecosystem":"Packagist","fixed":["5.10.3"],"introduced":["5.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-9p7c-v5x3-rfx8"}],"prev":{"headline":"Formbricks Survey actions.ts access control","id":"CVE-2026-14792"},"products":["CMS"],"published":"2026-07-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-06","vendors":["Craft"]},"summary":"Remote attackers can bypass authorization checks in the reorder-sets endpoint to modify global sets without proper permissions.","url":"https://insights.sbomify.com/CVE-2026-14793/"}