# CVE-2026-14793: Craft CMS reorder-sets Endpoint GlobalsController.php actionReorderSets authorization

> Remote attackers can bypass authorization checks in the reorder-sets endpoint to modify global sets without proper permissions.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-9p7c-v5x3-rfx8

## What is CVE-2026-14793?

CVE-2026-14793 is a medium-severity missing authorization vulnerability in Craft CMS, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was detected in Craft CMS up to 4.18.0.1. Affected is the function actionReorderSets of the file src/controllers/GlobalsController.php of the component reorder-sets Endpoint. The manipulation results in authorization bypass. The attack can be executed remotely. Upgrading to version 4.18.1 is able to address this issue. The patch is identified as 9bd05c91e6a7e6da5e949ec41a31c220c059aa04. The affected component should be upgraded.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-14793?

4 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.18.1 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.18.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.3 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.3 |

## How do I fix CVE-2026-14793?

Upgrade craftcms/cms to a fixed version for your release line: 4.18.1 or 5.10.3.

## Is CVE-2026-14793 being exploited?

There is no known exploitation of CVE-2026-14793 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14793 and fix it if it is affected.

What it is: CVE-2026-14793 is a medium-severity missing authorization vulnerability in Craft CMS, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14793 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.1
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.3
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14793/ (Markdown: https://insights.sbomify.com/CVE-2026-14793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14793
- OSV: https://osv.dev/vulnerability/CVE-2026-14793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14793/
Summaries are generated and may contain mistakes; the official description above is the record.
