CVE-2026-14794 Craft CMS Charts Endpoint ChartsController.php actionGetNewUsersData improper authorization
Remote attackers can bypass authorization checks in the Charts endpoint to access unauthorized user data in Craft CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-14794?
CVE-2026-14794 is a medium-severity missing authorization vulnerability in Craft CMS, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw has been found in Craft CMS up to 4.18.0.1. Affected by this vulnerability is the function actionGetNewUsersData of the file src/controllers/ChartsController.php of the component Charts Endpoint. This manipulation of the argument userGroupId causes improper authorization. The attack is possible to be carried out remotely. Upgrading to version 4.18.1 addresses this issue. Patch name: 9ee53efc1314e6aba32771c66a13e072a246f4ce. It is suggested to upgrade the affected component.
Which versions are affected by CVE-2026-14794?
4 open source packages ship an affected version, including craftcms/cms.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.18.1 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.18.1 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.10.3 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.10.3 |
How do I fix CVE-2026-14794?
Upgrade craftcms/cms to a fixed version for your release line: 4.18.1 or 5.10.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-14794 being exploited?
There is no known exploitation of CVE-2026-14794 in the wild and no public exploit code.
Sources
Also known as GHSA-rvmm-v933-jgxq.