# CVE-2026-14794: Craft CMS Charts Endpoint ChartsController.php actionGetNewUsersData improper authorization

> Remote attackers can bypass authorization checks in the Charts endpoint to access unauthorized user data in Craft CMS.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-rvmm-v933-jgxq

## What is CVE-2026-14794?

CVE-2026-14794 is a medium-severity missing authorization vulnerability in Craft CMS, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw has been found in Craft CMS up to 4.18.0.1. Affected by this vulnerability is the function actionGetNewUsersData of the file src/controllers/ChartsController.php of the component Charts Endpoint. This manipulation of the argument userGroupId causes improper authorization. The attack is possible to be carried out remotely. Upgrading to version 4.18.1 addresses this issue. Patch name: 9ee53efc1314e6aba32771c66a13e072a246f4ce. It is suggested to upgrade the affected component.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-14794?

4 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.18.1 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.18.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.3 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.3 |

## How do I fix CVE-2026-14794?

Upgrade craftcms/cms to a fixed version for your release line: 4.18.1 or 5.10.3.

## Is CVE-2026-14794 being exploited?

There is no known exploitation of CVE-2026-14794 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14794 and fix it if it is affected.

What it is: CVE-2026-14794 is a medium-severity missing authorization vulnerability in Craft CMS, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14794 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.1
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.3
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14794/ (Markdown: https://insights.sbomify.com/CVE-2026-14794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14794
- OSV: https://osv.dev/vulnerability/CVE-2026-14794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14794/
Summaries are generated and may contain mistakes; the official description above is the record.
