CVE-2026-14814 Permissive Regular Expression in GitLab

High 8.2 Published Updated

Attackers can poison cached repository files to execute malicious code in CI/CD pipelines and expose protected environment variables.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-14814?

CVE-2026-14814 is a high-severity code injection vulnerability in Gitlab Gitlab, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed a user to poison cached responses for raw repository files, causing targeted users' CI/CD pipelines to execute specially crafted content and potentially exposing protected environment variables, due to improper validation of repository references.

Weakness: CWE-625

Which versions are affected by CVE-2026-14814?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions19.2.8, 19.3.5, 19.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-14814?

Upgrade gitlab to a fixed version for your release line: 19.2.8, 19.3.5 or 19.4.2.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-14814 being exploited?

There is no known exploitation of CVE-2026-14814 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-14814, GHSA-49c6-8ph4-9vr9, MINI-2pxx-9v36-h87w, MINI-366c-wrrm-9h6q, MINI-4rhf-836g-2jfg, MINI-4xw2-xj2v-p8h5 and 48 more.

Is CVE-2026-14814 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free