# CVE-2026-14886: Vault Enterprise vulnerable to cross-namespace entity deletion

> Authenticated users can bypass namespace restrictions to permanently delete entity storage in other namespaces.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** BIT-vault-2026-14886, GHSA-rmq8-5gxg-mjqx, MINI-c3g5-fc3r-cgc9

## What is CVE-2026-14886?

CVE-2026-14886 is a high-severity missing authorization vulnerability in HashiCorp Vault Enterprise, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vault Enterprise's identity entity batch-delete endpoint is vulnerable to a cross-namespace authorization bypass that may allow an authenticated caller in one namespace to permanently delete the storage backing of entities belonging to another namespace. This vulnerability (CVE-2026-14886) is fixed in Vault Enterprise 2.0.4, 1.21.9, 1.20.14 and 1.19.20.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-14886?

1 open source package ship an affected version, including vault.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | From 2.0.0 | 2.0.4 |

## How do I fix CVE-2026-14886?

Upgrade vault to 2.0.4 or later.

## Is CVE-2026-14886 being exploited?

There is no known exploitation of CVE-2026-14886 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14886 and fix it if it is affected.

What it is: CVE-2026-14886 is a high-severity missing authorization vulnerability in HashiCorp Vault Enterprise, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14886 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected from 2.0.0; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14886/ (Markdown: https://insights.sbomify.com/CVE-2026-14886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14886
- OSV: https://osv.dev/vulnerability/CVE-2026-14886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14886/
Summaries are generated and may contain mistakes; the official description above is the record.
