{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-14943 exists.","fix":"No fix has been published for CVE-2026-14943 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-14943 is a high-severity vulnerability in Unknown Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-14943 and fix it if it is affected.\n\nWhat it is: CVE-2026-14943 is a high-severity vulnerability in Unknown Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-14943 exists.\n\nAffected product: Unknown Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-14943/ (Markdown: https://insights.sbomify.com/CVE-2026-14943/index.md)","id":"CVE-2026-14943","markdown":"https://insights.sbomify.com/CVE-2026-14943/index.md","name":"CVE-2026-14943","record":{"aliases":["GHSA-qmm8-q2c2-c4m3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can bypass password protection to read protected content and account identifiers via the REST API when a specific option is enabled.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content WordPress plugin before 2.8.4 does not restrict REST API access to authenticated users when a specific option is enabled, allowing unauthenticated visitors to bypass the sitewide password gate and read otherwise-protected content and account identifiers via the REST API. This re-introduces a previously-fixed issue (CVE-2024-0437), which was patched in 2.6.7 and regressed in 2.6.8.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Password Protected \u003c 2.8.4 - Unauthenticated Sensitive Information Exposure via REST API","id":"CVE-2026-14943","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"File upload in FDS 102","id":"CVE-2026-14946"},"packages":[],"prev":{"headline":"This CVE ID was assigned to a reported vulnerability in the Customer Reviews for WooCommerce WordPress plugin and was never published.","id":"CVE-2026-14942"},"products":["Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content"],"published":"2026-08-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-07","vendors":["Unknown"]},"summary":"Unauthenticated attackers can bypass password protection to read protected content and account identifiers via the REST API when a specific option is enabled.","url":"https://insights.sbomify.com/CVE-2026-14943/"}