CVE-2026-1500 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause denial of service in GitLab by uploading a specially crafted file that triggers uncontrolled resource consumption.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1500?

CVE-2026-1500 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.10 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an authenticated user to cause denial of service due to uncontrolled resource consumption when processing a specially crafted file upload.

Weakness: CWE-770

Which versions are affected by CVE-2026-1500?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.10.018.10.8, 18.11.5, 19.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-1500?

Upgrade gitlab to a fixed version for your release line: 18.10.8, 18.11.5 or 19.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-1500 being exploited?

There is no known exploitation of CVE-2026-1500 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1500, GHSA-jfx9-cc6f-6x6q.

Is CVE-2026-1500 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free