CVE-2026-15007 Denial of service in Enterprise Server

Medium 5.7 Published Updated

An authenticated user can cause service disruption in GitHub Enterprise Server by submitting deeply nested YAML in release notes configuration.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-15007?

CVE-2026-15007 is a medium-severity denial of service vulnerability in GitHub Enterprise Server, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to cause service disruption by supplying a repository release notes configuration file containing deeply nested YAML. When release notes were generated, the configuration file was parsed without a nesting depth limit, causing excessive resource consumption that could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.18, 3.18.12, 3.19.9, 3.20.5, and 3.21.3. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-770

Which versions are affected by CVE-2026-15007?

How do I fix CVE-2026-15007?

No fix has been published for CVE-2026-15007 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-15007 being exploited?

There is no known exploitation of CVE-2026-15007 in the wild and no public exploit code.

Sources

Also known as GHSA-x3vv-vhr6-576j.

Is CVE-2026-15007 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free