{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-15007 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-15007 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-15007 is a medium-severity denial of service vulnerability in GitHub Enterprise Server, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-15007 and fix it if it is affected.\n\nWhat it is: CVE-2026-15007 is a medium-severity denial of service vulnerability in GitHub Enterprise Server, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-15007 in the wild and no public exploit code.\n\nAffected product: GitHub Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-15007/ (Markdown: https://insights.sbomify.com/CVE-2026-15007/index.md)","id":"CVE-2026-15007","markdown":"https://insights.sbomify.com/CVE-2026-15007/index.md","name":"CVE-2026-15007","record":{"aliases":["GHSA-x3vv-vhr6-576j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub Enterprise Server","requires_auth":"low_privilege","summary":"An authenticated user can cause service disruption in GitHub Enterprise Server by submitting deeply nested YAML in release notes configuration.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_P","cpe":[],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:U","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to cause service disruption by supplying a repository release notes configuration file containing deeply nested YAML. When release notes were generated, the configuration file was parsed without a nesting depth limit, causing excessive resource consumption that could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.18, 3.18.12, 3.19.9, 3.20.5, and 3.21.3. This vulnerability was reported via the GitHub Bug Bounty program.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Denial of service in Enterprise Server","id":"CVE-2026-15007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"Deserialization in Uncanny Automator – Easy Automation, Integration, Webhooks \u0026 Workflow Builder Plugin","id":"CVE-2026-15008"},"packages":[],"prev":{"headline":"Bit integrations \u003c= 2.9.0 - Unauthenticated Arbitrary File Read via Optional CF7 File Field","id":"CVE-2026-15006"},"products":["Enterprise Server"],"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-17","vendors":["GitHub"]},"summary":"An authenticated user can cause service disruption in GitHub Enterprise Server by submitting deeply nested YAML in release notes configuration.","url":"https://insights.sbomify.com/CVE-2026-15007/"}