# CVE-2026-15007: Denial of service in Enterprise Server

> An authenticated user can cause service disruption in GitHub Enterprise Server by submitting deeply nested YAML in release notes configuration.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-x3vv-vhr6-576j

## What is CVE-2026-15007?

CVE-2026-15007 is a medium-severity denial of service vulnerability in GitHub Enterprise Server, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to cause service disruption by supplying a repository release notes configuration file containing deeply nested YAML. When release notes were generated, the configuration file was parsed without a nesting depth limit, causing excessive resource consumption that could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.18, 3.18.12, 3.19.9, 3.20.5, and 3.21.3. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-15007?


## How do I fix CVE-2026-15007?

No fix has been published for CVE-2026-15007 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-15007 being exploited?

There is no known exploitation of CVE-2026-15007 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15007 and fix it if it is affected.

What it is: CVE-2026-15007 is a medium-severity denial of service vulnerability in GitHub Enterprise Server, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-15007 in the wild and no public exploit code.

Affected product: GitHub Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15007/ (Markdown: https://insights.sbomify.com/CVE-2026-15007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15007
- OSV: https://osv.dev/vulnerability/CVE-2026-15007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15007/
Summaries are generated and may contain mistakes; the official description above is the record.
