# CVE-2026-15144: @fastify/rate-limit vulnerable to rate-limit bypass via IPv6 address rotation

> Attackers can bypass rate limits in Fastify applications by rotating IPv6 addresses, exposing protected endpoints to abuse.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-grpc-p53c-r64v

## What is CVE-2026-15144?

CVE-2026-15144 is a high-severity vulnerability in @fastify/rate-limit, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/rate-limit before 11.2.0 keys rate-limit buckets by the verbatim client IP string returned from request.ip. Because a single IPv6 client can control a large address range (a /64 holds 2^64 distinct addresses) and the same address has multiple valid textual representations, an IPv6 capable client can defeat the rate-limit boundary by rotating addresses or by rewriting the same address in different forms. Applications that use @fastify/rate-limit to protect endpoints such as authentication, password reset, OTP delivery, or expensive API calls can be bypassed by IPv6 clients behind a proxy that surfaces IPv6 to the origin when trustProxy is enabled. The issue is fixed in @fastify/rate-limit 11.2.0, where the default key generator normalizes IPv6 addresses to their canonical form, collapses IPv4 mapped IPv6 to IPv4, and applies a configurable prefix mask (default /64) via a new ipv6Subnet option.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-15144?

It affects 1 product.


Products: Fastify Fastify\/Rate-Limit.

## How do I fix CVE-2026-15144?

No fix has been published for CVE-2026-15144 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-15144 being exploited?

There is no known exploitation of CVE-2026-15144 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15144 and fix it if it is affected.

What it is: CVE-2026-15144 is a high-severity vulnerability in @fastify/rate-limit, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-15144 in the wild and no public exploit code.

Affected product: @fastify/rate-limit. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15144/ (Markdown: https://insights.sbomify.com/CVE-2026-15144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15144
- OSV: https://osv.dev/vulnerability/CVE-2026-15144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15144/
Summaries are generated and may contain mistakes; the official description above is the record.
