CVE-2026-15157 undici vulnerable to CRLF Injection via blob-like body 'type' property
Attackers can inject CRLF sequences into HTTP headers via untrusted blob-like body types, enabling request smuggling in undici-based applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-15157?
CVE-2026-15157 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
undici does not validate the type property of a duck-typed blob-like request body before using it as the Content-Type header on the HTTP/1.1 dispatcher. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, an application that passes a hand-rolled blob-like body (via request, stream, pipeline, or dispatch) whose type is derived from untrusted input allows an attacker to inject CRLF sequences and append arbitrary HTTP headers, potentially smuggling a second request past the upstream. Native Blob objects are safe because their constructor strips CRLF from the type, and fetch is unaffected because it validates headers, but ecosystem libraries that build duck-typed blob shapes from user input can reach the vulnerable path. This is the same defect class as CVE-2022-35948 and CVE-2026-1527, on a header sink that the earlier fixes did not cover. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.
Weakness: CWE-93
Which versions are affected by CVE-2026-15157?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | All versions | 6.28.0 |
undici npm | All versions | 6.28.0 |
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 8.0.0 | 8.9.0 |
undici npm | From 8.0.0 | 8.9.0 |
Products include Nodejs Undici.
How do I fix CVE-2026-15157?
Upgrade undici to a fixed version for your release line: 6.28.0, 7.29.0 or 8.9.0.
Is CVE-2026-15157 being exploited?
There is no known exploitation of CVE-2026-15157 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as AZL-94440, CLEANSTART-2026-FK35606, CLEANSTART-2026-QY67277, CLEANSTART-2026-WC12371, DEBIAN-CVE-2026-15157, ECHO-2475-b050-49d1 and 27 more.