# CVE-2026-15157: undici vulnerable to CRLF Injection via blob-like body 'type' property

> Attackers can inject CRLF sequences into HTTP headers via untrusted blob-like body types, enabling request smuggling in undici-based applications.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 30 Jul 2026
- **Also known as:** AZL-94440, CLEANSTART-2026-FK35606, CLEANSTART-2026-QY67277, CLEANSTART-2026-WC12371, DEBIAN-CVE-2026-15157, ECHO-2475-b050-49d1, GHSA-m8rv-5g2x-5cg5, MINI-33w5-j6jc-4pw7, MINI-4jph-w3rx-3g95, MINI-56v5-rfcg-66r5, MINI-572j-58fp-g975, MINI-64hr-3499-p3wx, MINI-6gcw-29f6-3p36, MINI-8w3g-qjw5-838p, MINI-c73r-7hx9-vp8w, MINI-ffqw-57fm-vfp9, MINI-fv2p-cqhg-vv8v, MINI-fw3m-rjww-94hg, MINI-fx3f-xpm8-3gjr, MINI-hm2f-p9wv-48vg, MINI-jgq9-6562-9hrh, MINI-m9h2-8g5v-fwx4, MINI-p5vm-9cmj-m7q9, MINI-pxw7-v6mw-vmq5, MINI-q3pg-g579-vrwg, MINI-q59j-r957-pgwh, MINI-qhqp-vvgf-xqq2, MINI-rpw8-mr54-6j4x, MINI-w8f2-g343-g8p7, MINI-w9q3-rwvr-4qfh, MINI-whqj-5mfr-x4jv, ROOT-APP-NPM-CVE-2026-15157, UBUNTU-CVE-2026-15157

## What is CVE-2026-15157?

CVE-2026-15157 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

undici does not validate the type property of a duck-typed blob-like request body before using it as the Content-Type header on the HTTP/1.1 dispatcher. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, an application that passes a hand-rolled blob-like body (via request, stream, pipeline, or dispatch) whose type is derived from untrusted input allows an attacker to inject CRLF sequences and append arbitrary HTTP headers, potentially smuggling a second request past the upstream. Native Blob objects are safe because their constructor strips CRLF from the type, and fetch is unaffected because it validates headers, but ecosystem libraries that build duck-typed blob shapes from user input can reach the vulnerable path. This is the same defect class as CVE-2022-35948 and CVE-2026-1527, on a header sink that the earlier fixes did not cover. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-15157?

6 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | All versions | 6.28.0 |
| `undici` | npm | All versions | 6.28.0 |
| `undici` | npm | From 7.0.0 | 7.29.0 |
| `undici` | npm | From 7.0.0 | 7.29.0 |
| `undici` | npm | From 8.0.0 | 8.9.0 |
| `undici` | npm | From 8.0.0 | 8.9.0 |

Products: Nodejs Undici.

## How do I fix CVE-2026-15157?

Upgrade undici to a fixed version for your release line: 6.28.0, 7.29.0 or 8.9.0.

## Is CVE-2026-15157 being exploited?

There is no known exploitation of CVE-2026-15157 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15157 and fix it if it is affected.

What it is: CVE-2026-15157 is a medium-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-15157 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected all versions; fixed in 6.28.0
- undici (npm): affected all versions; fixed in 6.28.0
- undici (npm): affected from 7.0.0; fixed in 7.29.0
- undici (npm): affected from 7.0.0; fixed in 7.29.0
- undici (npm): affected from 8.0.0; fixed in 8.9.0
- undici (npm): affected from 8.0.0; fixed in 8.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15157/ (Markdown: https://insights.sbomify.com/CVE-2026-15157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15157
- OSV: https://osv.dev/vulnerability/CVE-2026-15157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15157/
Summaries are generated and may contain mistakes; the official description above is the record.
