{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15182 exists.","fix":"No fix has been published for CVE-2026-15182 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-15182 is a medium-severity memory corruption vulnerability in GNU LibreDWG, published on 9 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-15182 and fix it if it is affected.\n\nWhat it is: CVE-2026-15182 is a medium-severity memory corruption vulnerability in GNU LibreDWG, published on 9 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15182 exists.\n\nAffected product: GNU LibreDWG. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-15182/ (Markdown: https://insights.sbomify.com/CVE-2026-15182/index.md)","id":"CVE-2026-15182","markdown":"https://insights.sbomify.com/CVE-2026-15182/index.md","name":"CVE-2026-15182","record":{"aliases":["GHSA-3h8r-9w82-hxmh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"DWG file library","requires_auth":"low_privilege","summary":"A heap-based buffer overflow in GNU LibreDWG allows local attackers to execute arbitrary code or cause denial of service via crafted BMP images.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability has been found in GNU LibreDWG up to 0.13.4. The affected element is the function dwg_bmp of the file src/dwg.c of the component BMP Image Handler. Such manipulation leads to heap-based buffer overflow. The attack must be carried out locally. The exploit has been disclosed to the public and may be used. Upgrading to version 0.14 is sufficient to fix this issue. The name of the patch is 18fd542bb4d5ccedf9de12052bf50068b2b26f06. It is suggested to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"GNU LibreDWG BMP Image dwg.c dwg_bmp heap-based overflow","id":"CVE-2026-15182","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":10,"next":{"headline":"Input Validation Vulnerabilities in Snowflake Spark Connector","id":"CVE-2026-15183"},"packages":[],"prev":{"headline":"Tracking Code Manager \u003c= 2.6.0 - Reflected Cross-Site Scripting via 'TCM_ErrorMessages'","id":"CVE-2026-15180"},"products":["LibreDWG"],"published":"2026-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["GNU"]},"summary":"A heap-based buffer overflow in GNU LibreDWG allows local attackers to execute arbitrary code or cause denial of service via crafted BMP images.","url":"https://insights.sbomify.com/CVE-2026-15182/"}