# CVE-2026-15182: GNU LibreDWG BMP Image dwg.c dwg_bmp heap-based overflow

> A heap-based buffer overflow in GNU LibreDWG allows local attackers to execute arbitrary code or cause denial of service via crafted BMP images.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-3h8r-9w82-hxmh

## What is CVE-2026-15182?

CVE-2026-15182 is a medium-severity memory corruption vulnerability in GNU LibreDWG, published on 9 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in GNU LibreDWG up to 0.13.4. The affected element is the function dwg_bmp of the file src/dwg.c of the component BMP Image Handler. Such manipulation leads to heap-based buffer overflow. The attack must be carried out locally. The exploit has been disclosed to the public and may be used. Upgrading to version 0.14 is sufficient to fix this issue. The name of the patch is 18fd542bb4d5ccedf9de12052bf50068b2b26f06. It is suggested to upgrade the affected component.

Weakness: CWE-122 (Heap-based Buffer Overflow), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-15182?


## How do I fix CVE-2026-15182?

No fix has been published for CVE-2026-15182 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-15182 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15182 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15182 and fix it if it is affected.

What it is: CVE-2026-15182 is a medium-severity memory corruption vulnerability in GNU LibreDWG, published on 9 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15182 exists.

Affected product: GNU LibreDWG. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15182/ (Markdown: https://insights.sbomify.com/CVE-2026-15182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15182
- OSV: https://osv.dev/vulnerability/CVE-2026-15182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15182/
Summaries are generated and may contain mistakes; the official description above is the record.
