# CVE-2026-15184: GNU LibreDWG DWG File dwg.c dwg_next_entity null pointer dereference

> A local attacker can cause a denial of service via null pointer dereference in GNU LibreDWG by manipulating DWG file arguments.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-fgx7-4whx-rx6p

## What is CVE-2026-15184?

CVE-2026-15184 is a medium-severity vulnerability in GNU LibreDWG, published on 9 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in GNU LibreDWG up to 0.13.4. The impacted element is the function dwg_next_entity of the file src/dwg.c of the component DWG File Handler. Performing a manipulation of the argument next_obj results in null pointer dereference. The attack must be initiated from a local position. The exploit has been made public and could be used. Upgrading to version 0.14 is sufficient to resolve this issue. The patch is named dde45dac3c4d902e4d8fed150a8017b9732019c9. Upgrading the affected component is recommended. Different than CVE-2026-9503.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2026-15184?


## How do I fix CVE-2026-15184?

Upgrade to a fixed version.

## Is CVE-2026-15184 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15184 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15184 and fix it if it is affected.

What it is: CVE-2026-15184 is a medium-severity vulnerability in GNU LibreDWG, published on 9 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-15184 exists.

Affected product: GNU LibreDWG. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15184/ (Markdown: https://insights.sbomify.com/CVE-2026-15184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15184
- OSV: https://osv.dev/vulnerability/CVE-2026-15184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15184/
Summaries are generated and may contain mistakes; the official description above is the record.
