CVE-2026-15217 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

An attacker can execute arbitrary scripts in the GitLab analytics dashboard via improper input neutralization, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-15217?

CVE-2026-15217 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 19.0.6, 19.1 before 19.1.4, and 19.2 before 19.2.2 that under certain conditions could have allowed cross-site scripting due to improper neutralization of user-controlled values rendered in table cell content by an analytics dashboard component.

Weakness: CWE-79

Which versions are affected by CVE-2026-15217?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.2.019.0.6, 19.1.4, 19.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-15217?

Upgrade gitlab to a fixed version for your release line: 19.0.6, 19.1.4 or 19.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-15217 being exploited?

There is no known exploitation of CVE-2026-15217 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-15217, GHSA-qqh6-p6j8-qj74, MINI-2rw8-66cm-x4f2, MINI-wg8q-8v8m-xj6g.

Is CVE-2026-15217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free