{"answers":{"affected":"2 open source packages ship an affected version, including neo4j-enterprise and neo4j. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-1524 in the wild and no public exploit code.","fix":"Upgrade neo4j-enterprise to a fixed version for your release line: 5.26.22 or 2026.2.0.","what":"CVE-2026-1524 is a low-severity authentication bypass vulnerability in neo4j Enterprise Edition, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-1524 and fix it if it is affected.\n\nWhat it is: CVE-2026-1524 is a low-severity authentication bypass vulnerability in neo4j Enterprise Edition, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-1524 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- neo4j-enterprise (Bitnami): affected all versions; fixed in 5.26.22, 2026.2.0\n- neo4j (Bitnami): affected all versions; fixed in 5.26.22, 2026.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1524/ (Markdown: https://insights.sbomify.com/CVE-2026-1524/index.md)","id":"CVE-2026-1524","markdown":"https://insights.sbomify.com/CVE-2026-1524/index.md","name":"CVE-2026-1524","record":{"aliases":["BIT-neo4j-2026-1524","BIT-neo4j-enterprise-2026-1524","GHSA-5pgp-mc2w-hjjx","MINI-5q3f-h297-whhp","MINI-63f7-pf2h-4q9w","MINI-6r74-gqhv-2x93","MINI-7h89-g3xv-q793","MINI-f5h5-4wh8-qmp4","MINI-hp5q-cm53-h55w","MINI-qm6h-9mxx-73v5","MINI-qpwj-5hjw-xwgq","MINI-vjjf-6856-g9fj","MINI-xffr-v886-f8f3"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Neo4j Enterprise Edition","requires_auth":"high_privilege","summary":"Misconfiguration in multi-provider SSO allows authentication-only providers to grant unintended authorization privileges, leading to unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Neo4j","cpe":[{"product":"neo4j","vendor":"neo4j"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/AU:N/R:U/V:D/RE:M/U:Green","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"An edgecase in SSO implementation in Neo4j Enterprise edition versions prior to version 2026.02 can lead to unauthorised access under the following conditions:\n\nIf a neo4j admin configures two or more OIDC providers AND configures one or more of them to be an authorization provider AND configures one or more of them to be authentication-only, then those that are authentication-only will also provide authorization. This edgecase becomes a security problem only if the authentication-only provider contains groups which have higher privileges than provided by the intended (configured) authorization provider.  \n\nWhen using multiple plugins for authentication and authorisation, prior to the fix the issue could lead to a plugin configured to provide only authentication or authorisation capabilities erroneously providing both capabilities. \n\nWe recommend upgrading to versions 2026.02 (or 5.26.22) where the issue is fixed.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth misconfiguration when multiple providers enabled","id":"CVE-2026-1524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"undici is vulnerable to Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')","id":"CVE-2026-1525"},"packages":[{"ecosystem":"Bitnami","fixed":["5.26.22","2026.2.0"],"introduced":["0","2025.1.0"],"last_affected":[],"package":"neo4j","purl":"pkg:bitnami/neo4j","source":"BIT-neo4j-2026-1524"},{"ecosystem":"Bitnami","fixed":["5.26.22","2026.2.0"],"introduced":["0","2025.1.0"],"last_affected":[],"package":"neo4j-enterprise","purl":"pkg:bitnami/neo4j-enterprise","source":"BIT-neo4j-enterprise-2026-1524"}],"prev":{"headline":"Path Traversal in Digitek from Grupo Azkoyen","id":"CVE-2026-1523"},"products":["Enterprise Edition"],"published":"2026-03-11","related":[{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in Neo4j","id":"CVE-2021-34371","kev_date_added":null,"published":"2021-08-05"},{"cvss_score":9.8,"headline":"Incorrect access control in Neo4j Enterprise Database Server via LDAP authentication","id":"CVE-2018-18389","kev_date_added":null,"published":"2018-10-16"},{"cvss_score":6.8,"headline":"Neo4J vulnerable to Cross-Site Request Forgery","id":"CVE-2013-7259","kev_date_added":null,"published":"2014-04-29"},{"cvss_score":6.5,"headline":"Neo4j Cypher component mishandles IMMUTABLE privileges","id":"CVE-2024-34517","kev_date_added":null,"published":"2024-05-07"},{"cvss_score":5.5,"headline":"Unathenticated connection can hold Bolt channel open","id":"CVE-2026-14587","kev_date_added":null,"published":"2026-08-05"},{"cvss_score":2.1,"headline":"Caching of authentication context","id":"CVE-2026-1471","kev_date_added":null,"published":"2026-03-11"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-12","vendors":["neo4j"]},"summary":"Misconfiguration in multi-provider SSO allows authentication-only providers to grant unintended authorization privileges, leading to unauthorized access.","url":"https://insights.sbomify.com/CVE-2026-1524/"}