# CVE-2026-1524: Auth misconfiguration when multiple providers enabled

> Misconfiguration in multi-provider SSO allows authentication-only providers to grant unintended authorization privileges, leading to unauthorized access.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/AU:N/R:U/V:D/RE:M/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** BIT-neo4j-2026-1524, BIT-neo4j-enterprise-2026-1524, GHSA-5pgp-mc2w-hjjx, MINI-5q3f-h297-whhp, MINI-63f7-pf2h-4q9w, MINI-6r74-gqhv-2x93, MINI-7h89-g3xv-q793, MINI-f5h5-4wh8-qmp4, MINI-hp5q-cm53-h55w, MINI-qm6h-9mxx-73v5, MINI-qpwj-5hjw-xwgq, MINI-vjjf-6856-g9fj, MINI-xffr-v886-f8f3

## What is CVE-2026-1524?

CVE-2026-1524 is a low-severity authentication bypass vulnerability in neo4j Enterprise Edition, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An edgecase in SSO implementation in Neo4j Enterprise edition versions prior to version 2026.02 can lead to unauthorised access under the following conditions:

If a neo4j admin configures two or more OIDC providers AND configures one or more of them to be an authorization provider AND configures one or more of them to be authentication-only, then those that are authentication-only will also provide authorization. This edgecase becomes a security problem only if the authentication-only provider contains groups which have higher privileges than provided by the intended (configured) authorization provider.  

When using multiple plugins for authentication and authorisation, prior to the fix the issue could lead to a plugin configured to provide only authentication or authorisation capabilities erroneously providing both capabilities. 

We recommend upgrading to versions 2026.02 (or 5.26.22) where the issue is fixed.

Weakness: CWE-863 (Incorrect Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-1524?

2 open source packages ship an affected version, including neo4j-enterprise and neo4j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neo4j-enterprise` | Bitnami | All versions | 5.26.22, 2026.2.0 |
| `neo4j` | Bitnami | All versions | 5.26.22, 2026.2.0 |

Products: Neo4j Neo4j.

## How do I fix CVE-2026-1524?

Upgrade neo4j-enterprise to a fixed version for your release line: 5.26.22 or 2026.2.0.

## Is CVE-2026-1524 being exploited?

There is no known exploitation of CVE-2026-1524 in the wild and no public exploit code.

## Other vulnerabilities in neo4j Enterprise Edition

- [CVE-2021-34371](https://insights.sbomify.com/CVE-2021-34371/): Deserialization of Untrusted Data in Neo4j (critical 9.8)
- [CVE-2018-18389](https://insights.sbomify.com/CVE-2018-18389/): Incorrect access control in Neo4j Enterprise Database Server via LDAP authentication (critical 9.8)
- [CVE-2013-7259](https://insights.sbomify.com/CVE-2013-7259/): Neo4J vulnerable to Cross-Site Request Forgery (medium 6.8)
- [CVE-2024-34517](https://insights.sbomify.com/CVE-2024-34517/): Neo4j Cypher component mishandles IMMUTABLE privileges (medium 6.5)
- [CVE-2026-14587](https://insights.sbomify.com/CVE-2026-14587/): Unathenticated connection can hold Bolt channel open (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1524 and fix it if it is affected.

What it is: CVE-2026-1524 is a low-severity authentication bypass vulnerability in neo4j Enterprise Edition, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1524 in the wild and no public exploit code.

Affected packages and fixed versions:
- neo4j-enterprise (Bitnami): affected all versions; fixed in 5.26.22, 2026.2.0
- neo4j (Bitnami): affected all versions; fixed in 5.26.22, 2026.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1524/ (Markdown: https://insights.sbomify.com/CVE-2026-1524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1524
- OSV: https://osv.dev/vulnerability/CVE-2026-1524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1524/
Summaries are generated and may contain mistakes; the official description above is the record.
