CVE-2026-15285 Cross-site scripting in The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce

Medium 6.4 Published Updated

Authenticated contributors can inject malicious scripts via the Button widget's custom attributes, potentially leading to code execution in the context of other users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-15285?

CVE-2026-15285 is a medium-severity cross-site scripting vulnerability in posimyththemes The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The Plus Addons for Elementor plugin for WordPress was vulnerable to Authenticated (Contributor+) Stored Cross-Site Scripting via the Button widget's `custom_attributes` setting in versions up to and including 6.4.11. The `render` function in `modules/widgets/tp_button.php` passed the raw `custom_attributes` string through `tp_senitize_js_input()`. This filter is bypassable. The issue is patched in version 6.4.12.

Weakness: CWE-79

Which versions are affected by CVE-2026-15285?

How do I fix CVE-2026-15285?

No fix has been published for CVE-2026-15285 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-15285 being exploited?

There is no known exploitation of CVE-2026-15285 in the wild and no public exploit code.

Sources

Also known as GHSA-653v-fpr2-j969.

Is CVE-2026-15285 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free