# CVE-2026-15285: Cross-site scripting in The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce

> Authenticated contributors can inject malicious scripts via the Button widget's custom attributes, potentially leading to code execution in the context of other users.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-653v-fpr2-j969

## What is CVE-2026-15285?

CVE-2026-15285 is a medium-severity cross-site scripting vulnerability in posimyththemes The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Plus Addons for Elementor plugin for WordPress was vulnerable to Authenticated (Contributor+) Stored Cross-Site Scripting via the Button widget's `custom_attributes` setting in versions up to and including 6.4.11. The `render` function in `modules/widgets/tp_button.php` passed the raw `custom_attributes` string through `tp_senitize_js_input()`. This filter is bypassable. The issue is patched in version 6.4.12.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-15285?


## How do I fix CVE-2026-15285?

No fix has been published for CVE-2026-15285 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-15285 being exploited?

There is no known exploitation of CVE-2026-15285 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-15285 and fix it if it is affected.

What it is: CVE-2026-15285 is a medium-severity cross-site scripting vulnerability in posimyththemes The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-15285 in the wild and no public exploit code.

Affected product: posimyththemes The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-15285/ (Markdown: https://insights.sbomify.com/CVE-2026-15285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-15285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-15285
- OSV: https://osv.dev/vulnerability/CVE-2026-15285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-15285/
Summaries are generated and may contain mistakes; the official description above is the record.
