{"answers":{"affected":"2 open source packages ship an affected version, including fog-kubevirt.","exploited":"There is no known exploitation of CVE-2026-1530 in the wild and no public exploit code.","fix":"Upgrade fog-kubevirt to 1.5.1 or later.","what":"CVE-2026-1530 is a high-severity vulnerability in Red Hat Satellite 6, published on 2 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-1530 and fix it if it is affected.\n\nWhat it is: CVE-2026-1530 is a high-severity vulnerability in Red Hat Satellite 6, published on 2 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-1530 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fog-kubevirt (RubyGems): affected all versions; fixed in 1.5.1\n- fog-kubevirt (RubyGems): affected all versions; fixed in 1.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1530/ (Markdown: https://insights.sbomify.com/CVE-2026-1530/index.md)","id":"CVE-2026-1530","markdown":"https://insights.sbomify.com/CVE-2026-1530/index.md","name":"CVE-2026-1530","record":{"aliases":["GHSA-m3hq-3qj8-c5fm"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby gem library","requires_auth":"low_privilege","summary":"Attackers can intercept and alter communications between Satellite and OpenShift due to disabled certificate validation in the fog-kubevirt library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"A flaw was found in fog-kubevirt. This vulnerability allows a remote attacker to perform a Man-in-the-Middle (MITM) attack due to disabled certificate validation. This enables the attacker to intercept and potentially alter sensitive communications between Satellite and OpenShift, resulting in information disclosure and data integrity compromise.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fog-kubevirt: fog-kubevirt: man-in-the-middle vulnerability due to disabled certificate validation","id":"CVE-2026-1530","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Foreman-kubevirt: foreman_kubevirt: man-in-the-middle due to insecure default ssl verification","id":"CVE-2026-1531"},"packages":[{"ecosystem":"RubyGems","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"fog-kubevirt","purl":null,"source":"GHSA-m3hq-3qj8-c5fm"},{"ecosystem":"RubyGems","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"fog-kubevirt","purl":"pkg:gem/fog-kubevirt","source":"GHSA-m3hq-3qj8-c5fm"}],"prev":{"headline":"Keycloak affected by improper invitation token validation","id":"CVE-2026-1529"},"products":["Red Hat Satellite 6","Red Hat Satellite 6.16 for RHEL 8","Red Hat Satellite 6.16 for RHEL 9","Red Hat Satellite 6.17 for RHEL 9"],"published":"2026-02-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["Red Hat"]},"summary":"Attackers can intercept and alter communications between Satellite and OpenShift due to disabled certificate validation in the fog-kubevirt library.","url":"https://insights.sbomify.com/CVE-2026-1530/"}