# CVE-2026-1530: Fog-kubevirt: fog-kubevirt: man-in-the-middle vulnerability due to disabled certificate validation

> Attackers can intercept and alter communications between Satellite and OpenShift due to disabled certificate validation in the fog-kubevirt library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-m3hq-3qj8-c5fm

## What is CVE-2026-1530?

CVE-2026-1530 is a high-severity vulnerability in Red Hat Satellite 6, published on 2 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in fog-kubevirt. This vulnerability allows a remote attacker to perform a Man-in-the-Middle (MITM) attack due to disabled certificate validation. This enables the attacker to intercept and potentially alter sensitive communications between Satellite and OpenShift, resulting in information disclosure and data integrity compromise.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-1530?

2 open source packages ship an affected version, including fog-kubevirt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fog-kubevirt` | RubyGems | All versions | 1.5.1 |
| `fog-kubevirt` | RubyGems | All versions | 1.5.1 |

## How do I fix CVE-2026-1530?

Upgrade fog-kubevirt to 1.5.1 or later.

## Is CVE-2026-1530 being exploited?

There is no known exploitation of CVE-2026-1530 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1530 and fix it if it is affected.

What it is: CVE-2026-1530 is a high-severity vulnerability in Red Hat Satellite 6, published on 2 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1530 in the wild and no public exploit code.

Affected packages and fixed versions:
- fog-kubevirt (RubyGems): affected all versions; fixed in 1.5.1
- fog-kubevirt (RubyGems): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1530/ (Markdown: https://insights.sbomify.com/CVE-2026-1530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1530
- OSV: https://osv.dev/vulnerability/CVE-2026-1530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1530/
Summaries are generated and may contain mistakes; the official description above is the record.
